Minecraft: Java Edition Username Issues
Incident Report for Tebex
Resolved
This incident has been resolved.
Posted May 16, 2020 - 21:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2020 - 20:13 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 16, 2020 - 20:01 UTC
Identified
We're currently experiencing issues with some username lookups failing when logging into Minecraft: Java Edition webstores. We have identified the cause and we are currently working towards a fix.
Posted May 16, 2020 - 20:00 UTC
This incident affected: Webstores.